Platform teilweise nicht verfügbar

Incident Report for ITscope GmbH

Postmortem

Hinweise zu den Problemen der Erreichbarkeit unserer Domains am 20./21. Oktober 2025 

--- English version below ---

 Am 20. und 21. Oktober kam es bei  einigen unserer Domains zu zeitweisen Problemen bei der DNS-Auflösung. Ursache war eine fehlerhafte Konfiguration, die am Montag, dem 20. Oktober, aktiviert wurde. Dadurch konnten einige DNS-Provider unsere Domains nicht korrekt auflösen. 

 Die Probleme wurden am 21. Oktober behoben. Unsere Services waren größtenteils nicht erreichbar, insbesondere Dienste, die direkt über die betroffenen Domains laufen. 

 Was war betroffen? 

  • Die ITscope Plattform (www.itscope.com/red) war teilweise nicht erreichbar. 
  • Die Angebotsplattform (itquote.de) war teilweise nicht erreichbar. 
  • Die Website (www.itscope.com) war teilweise nicht erreichbar. 
  • Die Statusseite (status.itscope.com) war teilweise nicht erreichbar. 
  • Zendesk (Support Tickets) war grundsätzlich erreichbar, hatte aber ebenfalls Einschränkungen durch einen parallelen AWS-Ausfall am 20. Oktober. 
  • Telefonisch waren wir teilweise nicht erreichbar. Dies lag ebenfalls an dem Ausfall unserer Domain. 

 

Was wurde unternommen? 

  • Die fehlerhafte Konfiguration wurde identifiziert und deaktiviert. 
  • Die DNS-Einträge werden aktuell weltweit neu verteilt.  

 

Ist das Problem behoben? 

Wir betrachten das Problem derzeit als gelöst, Sollten weiterhin Probleme bestehen – sei es in der Erreichbarkeit oder mit Funktionen unserer Produkte – wenden Sie sich bitte wie gewohnt an den Support. 

 

Warum hat die Behebung der DNS-Probleme am 20./21. Oktober so lange gedauert? 

Die Verzögerung bei der Behebung hatte mehrere Ursachen, die zusammengewirkt haben: 

  • Gleichzeitiger Ausfall bei AWS: Am Montagmorgen kam es zu einem größeren Ausfall in der AWS-Region „US-east-1“, in der auch die zentrale AWS DNS-Infrastruktur liegt. Dieser Ausfall hat die Fehlersuche zusätzlich erschwert. 
  • Technische Komplexität der DNS-Konfiguration: Die fehlerhafte DNS-Konfiguration führte dazu, dass manche DNS-Provider unsere Domains nicht mehr auflösen konnten. Die Diagnose war schwierig, da die Fehler nicht eindeutig sichtbar waren und sich je nach DNS-Provider unterschiedlich äußerten. 
  • Verzögerte DNS-Propagation: Selbst nach der Korrektur dauert es bis zu 24 Stunden, bis die Änderungen weltweit bei allen DNS-Servern wirksam werden. Das ist ein technischer Standardprozess, der sich leider nicht beschleunigen lässt.

Was tun wir, um solche Verzögerungen künftig zu vermeiden?

Wir verbessern stetig unsere internen Abläufe und die Überwachung unserer DNS-Infrastruktur. Ziel ist es, bei zukünftigen Vorfällen schneller reagieren und transparenter informieren zu können. 

 

Warum wurde ich nicht informiert? 

 Wir verstehen, dass es wichtig ist, bei einem Ausfall schnell informiert zu werden: Informationen zu aktuellen Störungen veröffentlichen wir auf unserer Statusseite status.itscope.com 

Auch wenn die Seite selbst nicht erreichbar ist, erhalten Sie bei Problemen alle Informationen als E-Mail, wenn Sie sich auf der Statusseite registrieren. Den aktuellen Vorfall können Sie ebenfalls dort nachlesen.

Was wir künftig besser machen wollen

Wir arbeiten stetig daran, unsere Prozesse weiter zu verbessern . Ziel ist es, Sie künftig schneller, transparenter und proaktiv zu informieren, sobald ein Problem erkannt wird. Dazu gehört auch, dass wir künftig alternative Kommunikationswege bereitstellen, die unabhängig von unseren Hauptdomains funktionieren. 

Wir danken Ihnen für Ihre Geduld und Ihr Verständnis – und stehen Ihnen bei weiteren Fragen jederzeit zur Verfügung. 

 


Information about the problems with the availability of our internet domains on October 20/21, 2025

On October 20 and 21, some of our domains experienced temporary problems with DNS resolution. This was caused by an incorrect configuration that was activated on Monday, October 20. As a result, some DNS providers were unable to resolve our domains correctly.

The problems were resolved on October 21. Most of our services were unavailable, especially those running directly on the affected domains.

What was affected?

  • The ITscope platform (www.itscope.com/red) was partially unavailable.
  • The quotation platform (itquote.de) was partially unavailable.
  • The website (www.itscope.com) was partially unavailable.
  • The status page (status.itscope.com) was partially unavailable.
  • Zendesk (support tickets) was generally available, but also experienced limitations due to a parallel AWS outage on October 20.
  • We were partially unavailable by phone. This was also due to the outage of our domain.

What was done?

  • The incorrect configuration was identified and deactivated.
  • The DNS entries are currently being redistributed worldwide.

Has the problem been fixed?

We currently consider the problem to be solved. If problems persist—whether in terms of accessibility or with the functionality of our products—please contact support as usual.

Why did it take so long to fix the DNS problems on October 20/21?

The delay in fixing the problem was due to several factors that combined:

  • Simultaneous outage at AWS: On Monday morning, there was a major outage in the AWS region “US-east-1,” which also houses the central AWS DNS infrastructure. This outage made troubleshooting even more difficult.
  • Technical complexity of the DNS configuration: The faulty DNS configuration meant that some DNS providers were no longer able to resolve our domains. Diagnosis was difficult because the errors were not clearly visible and manifested themselves differently depending on the DNS provider.
  • Delayed DNS propagation: Even after the correction, it takes up to 24 hours for the changes to take effect on all DNS servers worldwide. This is a standard technical process that unfortunately cannot be accelerated.

What are we doing to avoid such delays in the future?

We are constantly improving our internal processes and the monitoring of our DNS infrastructure. The goal is to be able to respond more quickly and provide more transparent information in the event of future incidents.

Why was I not informed?

We understand that it is important to be informed quickly in the event of an outage: We publish information about current disruptions on our status page status.itscope.com

Even if the page itself is unavailable, you will receive all information by email if you register on the status page. You can also read about the current incident there.

What we want to do better in the future

We are constantly working to further improve our processes. The goal is to inform you more quickly, transparently, and proactively in the future as soon as a problem is detected. This also includes providing alternative communication channels in the future that function independently of our main domains.

We thank you for your patience and understanding—and are available to answer any further questions you may have.

Posted Oct 23, 2025 - 15:26 CEST

Resolved

Der DNS Incident wurde gelöst, die Systeme sollten von überall wieder erreichbar sein.
In einer Folge-Nachricht werden wir ein ausführliches Post-Mortem senden, um Sie über die Hintergründe des Ausfalls zu informieren.

---

The DNS incident has been resolved, and the systems should be accessible again from everywhere.
In a follow-up message, we will send a detailed post-mortem to inform you about the background of the outage.
Posted Oct 22, 2025 - 13:30 CEST

Monitoring

(English version below)
Update zur Erreichbarkeit der ITscope-Domains
Die technischen Maßnahmen zur Behebung der DNS-Probleme bei den Domains itscope.com und systemhaus.shop wurden erfolgreich umgesetzt. Wir beobachten derzeit die Situation aktiv, um sicherzustellen, dass die Lösung wie erwartet greift. Wir sehen, dass die ersten DNS resolver (z.B. Cloudflare) die korrekten Einträge liefern.
Bitte beachten Sie, dass es aufgrund der dezentralen Natur von DNS weiterhin vereinzelt zu Einschränkungen kommen kann, bis sich alle DNS-Server weltweit aktualisiert haben.
Wir danken Ihnen für Ihre Geduld und Ihr Vertrauen.
---
Update on ITscope Domain Accessibility
The technical measures to resolve the DNS issues affecting itscope.com and systemhaus.shop have been successfully implemented. We are now actively monitoring the situation to ensure the fix is working as expected. We can see, that the first DNS resolvers (e.g. cloudflare) return the correct values.
Please note that, due to the distributed nature of DNS, some users may still experience temporary access issues until all DNS servers have fully propagated the changes.
We appreciate your patience and continued trust.
Posted Oct 21, 2025 - 11:15 CEST

Update

(English version below)
Aktuell kommt es zu Problemen bei der DNS-Auflösung der Domains itscope.com und systemhaus.shop. Ursache hierfür sind Nachwirkungen des gestrigen Ausfalls in der AWS-Region „us-east“, insbesondere im Zusammenhang mit dem DNS-Dienst Route 53.
Infolge dessen kann der Zugriff auf unsere Website und Portale von bestimmten Standorten aus vorübergehend eingeschränkt sein. Wir wissen, wie wichtig eine zuverlässige Erreichbarkeit ist, und möchten Ihnen versichern, dass unser Technikteam bereits an einer Lösung arbeitet. Wir gehen davon aus, dass die vollständige Erreichbarkeit innerhalb der nächsten Stunden wiederhergestellt wird.
Vielen Dank für Ihre Geduld und Ihr Verständnis.

---

We are currently experiencing DNS resolution issues affecting the domains itscope.com and systemhaus.shop. This is a residual impact of the AWS us-east outage yesterday, specifically related to the Route 53 DNS service.
As a result, access to our website and portals may be temporarily unavailable from certain locations. We understand how important reliable access is, and we want to assure you that our technical team is actively working on a solution. We expect full accessibility to be restored within the next few hours.
Thank you for your patience and understanding.
Posted Oct 21, 2025 - 10:18 CEST

Update

Wir konnten die Ursache identifizieren und arbeiten gerade an einer Behebung.
Posted Oct 21, 2025 - 07:12 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 07:10 CEST
This incident affected: Platform (Platform ITscope.com, B2B Customer Portals) and API (ITscope API, ITscope Export).